3 way valve - No manual overide


Postby Fasil Bawlty » Sun May 13, 2007 3:09 pm

I enjoy reading threads on this forum and have found it very useful for DIY.

I'd appreciate some help with a problem:

No CH at all. HW works fine when selected. I suspected the 3-way valve is at fault as I have checked other parts.

The valve is noisey and buzzing. I can not motor the valve electrically (using heating controls - although HW & CH LEDs are lit on actuator). I can not manually operate the valve either - it is restricted, before I reach the holding gate.

How do I find out whether this is an electrical problem or mechanical? (although I suspect mech)

If I remove the actuator will the valve leak water? Is it possible to exercise this valve by hand? How?

Will attempting to operate the actuator whilst it is removed cause further damage?

Thanks.

Fasil.
Fasil Bawlty
Posts: 2
Joined: Sun May 13, 2007 2:52 pm

Sponsor

Simply Build It

Postby Paul Pepper » Tue May 15, 2007 6:48 pm

chances are the valve body is blocked (probably by it's own internals) and it's need changing. Doubt you'll be able to free it up by removing the head if it point blank refuses to go past a certain point.

Paul
Paul Pepper
Posts: 38
Joined: Fri May 11, 2007 6:02 pm


Postby Fasil Bawlty » Mon May 28, 2007 2:59 pm

Hmm, it seems like it might be a complete 3-way valve/actuator replacement!

I have removed the actuator from the valve and have then turned on the central heating. The solenoid buzzes but does not turn.

The actuator is a myson power extra 322 and will need replacing/fixing.

However, the valve itself appears to have a very slight water leak (less than a drip/hr) and there is corrosion running down from the spindle on the face plate. The spindle does move freely.

I think I will have to replace the valve also.

Can either part be fixed?
Fasil Bawlty
Posts: 2
Joined: Sun May 13, 2007 2:52 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics