adhsive didn't stick on the wall tile


Postby SUNSIN » Sat Oct 04, 2008 2:12 pm

i was doing the tiling in the bathroom.the wall in the bathroom coverd in plastboad which was been sealed with PVA.the problem is that when i tiling,during the working,i could feel the adhsive working very well with the tiles as i try to move it but it been stick firmly on the wall.but after a half-and-hour and the some of them after few hours came off the wall,even i couldn't see any marks on the back of the tiles. i also put some adhsive on the tiles whilst i put that on the wall,but that happend again,no adhsive and any marks on the back of the tiles either. the way i was doing as i done that before,but i'm relly don't know what's this going on this time!!Please help! :? :cry: :? :? :? :? cry: [/u][/i][/b]
SUNSIN
Posts: 1
Joined: Sat Oct 04, 2008 1:27 pm

Sponsor

Simply Build It

Postby tilewize » Fri Oct 10, 2008 10:50 pm

Sounds like the adhesive you are using isn't up to much if its ready mixed adhesive and grout i would bin it straight away not worth the time or money. Ready mixed adhesive and a powdered grout is what Ive used for the last 7 years with no problems with tiles falling off.

If you think the adhesive is sound i would check the instructions on the tub because all the big name adhesive suppliers recommend you don't P.V.A coat the walls as it acts as a barrier between wall and adhesive in which the adhesive will dry out quicker and advises a bonding agent is applied to walls prior to tiling
tilewize
Posts: 4
Joined: Sun Apr 08, 2007 7:52 pm


Postby chris_on_tour2002 » Mon Oct 13, 2008 10:38 pm

tilewize - what do you mean by bonding agent? is a latex primer a bonding agent?
chris_on_tour2002
Posts: 1023
Joined: Thu Aug 30, 2007 9:14 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics