Ariston EuroCombi Boiler - help needed


Postby Svenbo » Fri Jul 03, 2009 1:46 pm

Hello All,

Just signed up to the forum as I have a problem with my Ariston EuroCombi boiler.

Essentially, the boiler now fails to ignite when I turn a hot tap on - as such, I'm having to turn the heating on everytime I need to use hotwater (the boiler still ignites when the heating is turned on). As you can imagine, this isn't ideal given the hot weather at the moment!

Does anyone have any idea as to what's gone wrong with the boiler? My guess is it's 5-6 years old but as it still works for the heating, I'm hoping it will just need a sensor replaced or something rather than me needing to buy a new boiler.

Any advice gratefully received!
Svenbo
Posts: 3
Joined: Fri Jul 03, 2009 1:41 pm

Sponsor

Simply Build It

Postby htg engineer » Fri Jul 03, 2009 2:12 pm

Probable a split or stretched diaphragm in the diverter valve.


htg
htg engineer
Posts: 3193
Joined: Tue May 22, 2007 5:22 pm


Postby Svenbo » Fri Jul 03, 2009 2:35 pm

Thanks! Any idea how much that would cost to get fixed?
Svenbo
Posts: 3
Joined: Fri Jul 03, 2009 1:41 pm


Postby htg engineer » Sat Jul 04, 2009 6:51 pm

Should be under £20 for the diaphragm/service kit. Sometimes only £3 or £4 but it depends on the manufacturer.

As for the labour, i'm not too sure as i've never done one myself on the Ariston's but I can't see it being too difficult, check the instruction manual it may be possible for you to do it if you're a competent DIyer.


htg
htg engineer
Posts: 3193
Joined: Tue May 22, 2007 5:22 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics