Black Particles in Water From Cold Taps


Postby megacoup » Wed Nov 29, 2017 9:56 pm

Hi all


I am having black particles from all of my cold taps which stain and smudge when i try to remove them. From what I can see and have read it appears to be rubber suggesting something is degrading. A welsh water engineer visited and was very helpful but we couldn't locate the cause, the following day he took a sample from the mains which was clear, thinking it was an issue on my end. I have also had a plumber look at this and he is also unsure of what the problem could be as I have no flexi hoses and this problem only effects the cold taps being unlikely all the washers are failing , he thinks it is probably in the hot water but is most likely at the bottom of storage tank as sediment so I don't see it coming from the hot taps.

something did come to me today, I am metered could it possibly be the O ring inside the meter itself causing this problem ? Or some other rubber parts that could degrade ? I am at a complete loss, the water company says its an internal problem and the plumber who visited thinks it is coming from beyond my property.

Any help would be much appreciated

Thanks
megacoup
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Wed Nov 29, 2017 9:45 pm

Sponsor

Simply Build It


  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics