Boiler Halstead Ace High Hot water issue


Postby saqibkm » Fri Jul 06, 2007 10:06 am

I am having problem with my combi boiler, {Halstead Ace High}. On opening the hot water tap, the boiler work fine but after 5 min running then burner goes off suddenly. I do not see any fault light on display /PCB either.

As the water turns cold and I turns the hot water tap off and on again. the boiler makessome checksbut fail to ignite. It appears that the pump is running. when theburner is off but no ventilation fan is not working either. Moving the control button to RESET button in 50% cases would reignite the burner. It appears that boiler is over heating and safety thermostat iscutting off yet ther is n't a lock out light as the Halsted fault finding diagram suggests.

Somebody in the trade suggestedto change the Air Pressure Switch. I have changed this APS but It has not solved the problem. after 10-15 minutes the boiler works again for anther 5-10 minutes.
Please suggest a solution for this misfiring of boiler.

thanks
saqibkm
Posts: 2
Joined: Fri Jul 06, 2007 9:30 am

Sponsor

Simply Build It

Postby sparx » Mon Jul 23, 2007 7:24 pm

HI , suggest you repost this in central heating,air con forum, more likely some one knows your boiler there,
sparx
Posts: 2166
Joined: Wed Mar 21, 2007 8:33 pm
Location: The fifth continent.


Postby TheDoctor5 » Tue Jan 20, 2009 11:28 am

Last year 64% of the questions asked in our forum were answered within our DIY project pages at www.diydoctor.org.uk/projects.htm The project pages are now separated alphabetically and your answers are accompanied by diagrams and the ability to see, and buy, the tools and/or required to complete your project. Use our search box to look for your answer and save a great deal of time and money!
TheDoctor5
Site Admin
Posts: 1385
Joined: Tue Jan 20, 2009 9:17 am


Display posts from previous
Sort by
Order by


 


  • Related Topics