central heating combi boiler problem

Postby carter barter » Fri Dec 12, 2008 10:02 am

I have a Ideal C80FF combi boiler that is playing up. The problem is the presure keeps droping down to zero but when I presurise back up to 1Bar it runs ok but the preasure soon rises up to 3bar I then turn the heating off and it soon drops back down to 1Bar and below. Any Ideas?[/b]
carter barter
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Fri Dec 12, 2008 9:40 am


Simply Build It

Postby Steve the gas » Fri Dec 12, 2008 3:34 pm


Check the expansion vessel, it has a schrader valve,check pressure in it.
It should be 0.8 - 1 bar, diaphragm could have failed.
Don't be too worried about the 3 bar pressure the PRV will dump the water outside.

If this is worrying you - get an RGI in.

Steve the gas
Rank: Site Agent
Progress to next rank:
Posts: 780
Joined: Sun May 04, 2008 7:07 am

Postby htg engineer » Sat Dec 13, 2008 10:08 am

As stg says - it'll be the expansion vessel at fault. Press the valve on the expansion vessel.

Air ? re-pressurise
Water ? the diaphragm is shot and you need a new vessel.

htg engineer
Rank: Project Manager
Posts: 3224
Joined: Tue May 22, 2007 5:22 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics