Central heating/ water won't turn off


Postby Cherokee » Wed Oct 07, 2009 9:36 am

Hi
A couple of days ago my heating stayed on ofter the set time.
The red led light on the programmer was off, the thermostat in the hall wasn't clicking or controlling the heat, and the SELECT button although the arrow was moving from TWICE to ONCE to ON and the to OFF position none of the the settings were having an effect on the heating.
The above has aslo happened again but the difference was the red LEDs were on after the timer should have switched the heating off.
The rads weren't very hot though on both occassions.
If you press the advance button a few times sometimes you can get it to stop, but not always.

It has since happened on hot water only aswell.
I have had to turn the power to the boiler off to stop it but as soon as i turn it back on it starts up again.

It's not happening all the time, this morning the heating and water came on and went off fine!

Boiler is Ideal Classic, Programmer is Drayton LP241 with a Drayton Thermostat.

I hope i have explained it OK?

Any help would be appriciated.
Amanda
Cherokee
Posts: 2
Joined: Wed Oct 07, 2009 9:24 am

Sponsor

Simply Build It

Postby plumbbob » Wed Oct 07, 2009 11:39 pm

If we discount a frost stat set too high, as this is typical of the symptoms you describe, I would test the programmer as it could be faulty.

Mind you, it could also be a two or three port valve playing up, that is if you have got one.
plumbbob
Posts: 1854
Joined: Wed May 07, 2008 9:59 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics