Cool Radiator


Postby bugsy » Fri Nov 14, 2008 7:01 pm

Hi Everyone,

In my house i have several radiators and they all seem to be working fine except for the one in the TV lounge. This particular one is a lot cooler than the rest for some reason so i bled it but this did not do anything. It does have a TRV fitted but i have this on full so i am at a loss as to why it is not as hot as the others, any ideas?
bugsy
Posts: 3
Joined: Fri Nov 14, 2008 6:45 pm

Sponsor

Simply Build It

Postby nitro23456 » Sat Nov 15, 2008 8:52 pm

seized TRV pin or system not balanced.
nitro23456
Posts: 346
Joined: Sun Aug 12, 2007 6:19 pm


Postby Steve the gas » Sun Nov 16, 2008 5:49 am

Hi Bugsy,

It will be the pin sticking.
Take the trv head off by unscrewing the collar,then pull the small pin UP about 2-3mm, and a squirt of wd40 on it, voila!!

Hth
Steve the gas
Posts: 780
Joined: Sun May 04, 2008 7:07 am


Postby bugsy » Mon Nov 17, 2008 8:52 pm

[quote="nitro23456"]seized TRV pin or system not balanced.[/quote]

How does one go about balancing the system or do i need to call somebody in.
bugsy
Posts: 3
Joined: Fri Nov 14, 2008 6:45 pm


Postby bugsy » Mon Nov 17, 2008 8:57 pm

[quote="Steve the gas"]Hi Bugsy,

It will be the pin sticking.
Take the trv head off by unscrewing the collar,then pull the small pin UP about 2-3mm, and a squirt of wd40 on it, voila!!

Hth[/quote]

Tried this but the pin is already as high as it will go. However around the pin is an hexagonal shaped gold plate. If i were to loosen this(if it can be loosened) will it let the pin to be raised higher.
bugsy
Posts: 3
Joined: Fri Nov 14, 2008 6:45 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics

cron