Drayton 3 port valve


Postby horsleygc » Fri Jul 24, 2009 11:41 am

I have a Drayton 3 port valve on my vented system and can't get hot water only for the summer, it heats up radiators as well. I assume it is jammed open or blocked. Worked fine last summer; system is about 6 years old.
There are 3 positions for the front switch W-M-H. I remember it was at M but is now at H and I can't seem to coax it over. Don't want to force it in case it breaks off. Does this matter ? is this the problem ?
Have looked on Drayton web site but it offers no technical advice.
horsleygc
Posts: 1
Joined: Fri Jul 24, 2009 11:32 am

Sponsor

Simply Build It

Postby Steve the gas » Sat Jul 25, 2009 7:40 am

Yep replace head. Press black button on side and it comes off
Steve the gas
Posts: 780
Joined: Sun May 04, 2008 7:07 am


Postby rosebery » Sat Jul 25, 2009 9:24 am

You have to suspect the head first but I'd also check that the valve itself isn't that gumed up with crud that the head is having difficulty operating it.

Best way to check if its the head is rmove it form the valve body and watch it whilst someone operates the room stat to turn heating on and off. If valve is adjacent to the cylinder you can do the tank stat operation.

If its not working properly replace it. If it is I'd be checking the valve itself (but I'd be doing that as well even if replacing the head).

Cheers
rosebery
Posts: 2022
Joined: Wed Sep 26, 2007 8:55 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics