Dual push button flush toilet won't flush


Postby mingus_101 » Sun Dec 28, 2008 11:18 am

Hi
I have a push button toilet (has 2 buttons - 1 for short flush one for longer), had a few problems with it in the past with it not stopping flushing but that sorted itself out. Now it doesn't flush! The 2 buttons don't press down. I have to flush it but lifting the lid off the cistern and pressing the large button (inside the cistern) manually - which works, but the 2 buttons on the top of the cistern don't press down.
Often if I take the lid off press the large button and put the lid back on again the buttons will work for 1 or 2 flushes, then the problem starts again.
Its driving me nuts!
Any ideas what the problem might be and/or how I can fix it?

Thank you very much to anyone who replies
mingus_101
Posts: 1
Joined: Sun Dec 28, 2008 10:58 am

Sponsor

Simply Build It

Postby Steve the gas » Mon Dec 29, 2008 8:36 am

Hi,

Get a new syphon is what I would do - Dam things hate 'em.


Hth


You could try adjusting it tho,
Steve the gas
Posts: 780
Joined: Sun May 04, 2008 7:07 am


Postby TheDoctor5 » Mon Jan 26, 2009 9:27 am

Last year 64% of the questions asked in our forum were answered within our DIY project pages at www.diydoctor.org.uk/projects.htm The project pages are now separated alphabetically and your answers are accompanied by diagrams and the ability to see, and buy, the tools and/or required to complete your project. Use our search box to look for your answer and save a great deal of time and money!
TheDoctor5
Site Admin
Posts: 1385
Joined: Tue Jan 20, 2009 9:17 am


Display posts from previous
Sort by
Order by


 


  • Related Topics