Elan 2 boiler short running


Postby neil1050 » Tue Nov 24, 2009 11:33 pm

Hi there,
anyone out there with any specific experience of the Stelrad Ideal Elan 2 boilers ?

My late 80's model has done really well so far, it still starts & fires up ok, but will now only run for 3 mins or so.

I've already fitted a new overheat stat, & a thermocouple as the old one was burnt slightly short.

So I'm left thinking its a toss up between a High temp thermostat & the low temp stat ?

I work with massive industrial boilers at work, but could do with some help on the domestic ones.

Cheers :roll:
neil1050
Rank: Labourer
Progress to next rank:
50%
Posts: 3
Joined: Tue Nov 24, 2009 11:24 pm

Sponsor

Simply Build It

Postby DEEARR2 » Wed Nov 25, 2009 8:17 pm

Does the boiler reach any temperature before it shuts domn? Have you checked the pump operation?
DEEARR2
Rank: Ganger
Progress to next rank:
73.3%
Posts: 160
Joined: Sun Oct 12, 2008 8:49 pm

Postby neil1050 » Tue Dec 01, 2009 9:24 am

[quote="DEEARR2"]Does the boiler reach any temperature before it shuts domn? Have you checked the pump operation?[/quote]

Thanks for reply;

The pump runs fine, the boiler only runs for 3-4 mins or so, the pump outlet pipework & all the radiators round the house start to warm up when the boiler runs, then the boiler stops, hence the rads never get much more than hand hot for a few mins
neil1050
Rank: Labourer
Progress to next rank:
50%
Posts: 3
Joined: Tue Nov 24, 2009 11:24 pm

Postby neil1050 » Tue Dec 01, 2009 12:47 pm

[quote="neil1050"]Hi there,
anyone out there with any specific experience of the Stelrad Ideal Elan 2 boilers ?

My late 80's model has done really well so far, it still starts & fires up ok, but will now only run for 3 mins or so.

I've already fitted a new overheat stat, & a thermocouple as the old one was burnt slightly short.

So I'm left thinking its a toss up between a High temp thermostat & the low temp stat ?

I work with massive industrial boilers at work, but could do with some help on the domestic ones.

Cheers :roll:[/quote]


Now fitted hi temp stat, lo temp stat & rom stat, & still the same....
next methinks is to shut all the rads to try in recommission bleed/purge the system in case I managed to airlock /block the system near the boiler ?

This RS40 model doesn't appear to have a control pcb ?

Any clues as to what this prob could be ???
:oops: :?
neil1050
Rank: Labourer
Progress to next rank:
50%
Posts: 3
Joined: Tue Nov 24, 2009 11:24 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics