Electric and Normal Towel Radiator not working


Postby mishlondon » Tue Oct 09, 2007 11:13 am

Hi
My electric and normal radiator is not working?? Last winter and spring i was using it with normal heating and it was working ok. In summer i turned off the heating system and ocasionally i was using the radiaton with the electrical mode (valve closed and with electricity) and it worked. Now that i turn on the heating system all the radiators work except that one i took the air out i opened the valve so the water could run but nothing!!!
Any ideas what the problem is?? Any possible solutions??? Pls need help now that the winter is approaching
Thanks
mishlondon
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Tue Oct 09, 2007 11:03 am

Sponsor

Simply Build It

Postby The Heating Doctor » Thu Oct 11, 2007 11:56 pm

Some times on poorer quality radiator valves when you turn them back on the spindle snaps and although you think you are opening the valve it remains tight closed. The other thing is did you open both valves? As you have used the singular "valve" in your question.
The Heating Doctor
Rank: Foreman
Progress to next rank:
4.7%
Posts: 214
Joined: Mon Aug 27, 2007 9:49 am

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics