ELECTRIC SHOWER


Postby BARKER689 » Fri Mar 02, 2007 5:54 pm

I HAVE JUST FITTED MY 9.5KW ELECTRIC SHOWER AND WHEN I TURN ON THE POWER THE NEON LIGHT ON THE UNIT IS DIM AND FLICKERS THEN WHEN I TURN ON THE STOP/START BUTTON ON THERE IS NOTHING AND THE POWER LIGHT GOES OUT THEN I PRESS THE STOP/START BUTTON OFF AND THE POWER LIGHT COMES BACK ON AND AGAIN IS DIM AND FLICKERS I DO HAVE 240V AND A 40A FUSE MY PREVIOUS SHOWER WAS EXACTLY THE THE SAME WHICH I HAD FOR ABOUT 2 YEARS AND HAS JUST STOPPED WORKING IN THE SAME WAY ANY IDEAS THANKS
BARKER689
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Fri Mar 02, 2007 5:44 pm

Sponsor

Simply Build It

Postby stanley » Wed Mar 07, 2007 9:53 pm

you could check what ampage your incoming is, is it a 60 amps and are you overloading the system? what cable size have you to the shower.
stanley
Rank: Apprentice
Progress to next rank:
10.5%
Posts: 7
Joined: Mon Mar 05, 2007 10:33 am

Postby thedoctor » Fri Mar 16, 2007 2:34 pm

MANY OF THE ANSWERS TO YOUR POSTS CAN BE FOUND, WITH DIAGRAMS, IN THE DIYDOCTOR PROJECTS SECTION. CLICK HERE www.diydoctor.org.uk/projects.htm
thedoctor
Posts: 2406
Joined: Sat Apr 08, 2006 12:15 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics