Electronic Ballast or Circular Fluroscent Lamp issue?

Postby prabhakar76 » Sun Apr 29, 2012 11:24 am

I recently bought a light unit which has a 2GX13 Philips TL5C 40W lamp and Landlite EB-56 Electronic Ballast, it is low energy light from massive..

When I switch it on, the light comes on just for 2 seconds only, when I switch it off and on again immediately it doesn't work...if i wait for 3 -4 hours and switch it on, it again works for 2 seconds...

what could be the issue..can any one please help..

Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sun Apr 29, 2012 11:11 am


Simply Build It

Postby ericmark » Sun Apr 29, 2012 6:58 pm

Looking on the net it seems a few have problems with these ballast units. Reading what it says I would assume it's the auto shut down at end of life which is kicking in. One of the big problems with inverters is at end of life of tube it can take out the inverter/ballast as well.

If this is the case it's hard to work out which is at fault. As some ballast will run closer to end of life to others. Since tube is cheapest option I would tend to swap that first.

Other posts show that ballast being used with 2 x 13W are you sure correct match?
Rank: Project Manager
Posts: 1404
Joined: Fri Oct 02, 2009 8:49 pm
Location: Mold, North Wales.

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics