Ferroli help needed!

Postby desperateinmalvern » Wed Aug 29, 2012 8:35 pm

Hi, we have a Ferroli F30 that hasn't been working for either CH or HW for a while.

The low water pressure light is flashing despite the pressure gauge reading 1 bar. Having spoken to Ferroli I 'overrode' the low water pressure sensor by just joining the leads to it with a piece of wire and it worked fine, so I changed the water pressure sensor itself but that hasn't solved the issue. If anyone has any suggestions as to what else I can do I'd be very appreciative! Could changing the pressure gauge itself fix it? It seems to work fine as it rises/falls as I fill/bleed the system. Someone has mentioned that the flow and return valves could be jammed but I'm not sure what this means?

Many thanks in advance

Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Wed Aug 29, 2012 8:34 pm


Simply Build It

Postby plumbbob » Wed Aug 29, 2012 9:23 pm

If the boiler works when the pressure sensor is overridden, it seems unlikely that anything such as valves is at fault. Maybe the pressure gauge is incorrect and not showing the correct pressure?? Try increasing the pressure to 1.5bar and see if it works then.
Rank: Project Manager
Posts: 1872
Joined: Wed May 07, 2008 9:59 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics