gas fire works on low settings but cuts out on high settings

Postby j.venpin » Sat Nov 10, 2007 2:27 pm

[b] hi guys,

have a robinson willey gas fire, model firegem visa 2 with safeguard fitted
about 4 years ago , with multiflue outlet for the chimney. for some time now roughly over a few weeks ago the gas fire works on settings 1 and 2 but cuts out on high settings 3 and 4 and the pilot light cuts out as well. on settings 1 and 2 the fire appears to be producing less heat. what could be the problem and what would it cost roughly to fix it. on the other hand would it be better to buy a new gas fire and have it fitted by a corgi registered engineer.
joe v.[/b]
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sat Nov 10, 2007 1:27 pm


Simply Build It

Postby htg engineer » Sat Nov 10, 2007 8:12 pm

You need to get this checked by a CORGI registered installer, and it's probably best not to use it until is has been checked.

May be and probably is just dust or soot on pilot, but there's also a chance - if a oxy-pilot is fitted that it could be cutting out because there's not enough oxygen (there's carbon monoxide building up).
htg engineer
Rank: Project Manager
Posts: 3219
Joined: Tue May 22, 2007 5:22 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics