GLowworm Space Saver 38 problem


Postby chani1972 » Sun Feb 03, 2008 7:15 pm

Yesterday we had to drain our central heating system to fix a leaking joint, we drained the system, made the repair, refilled and bleed the system. Now we cant get our boiler to fire up (Glow worm Space saver 38) the programmer panel (Potterton EP2000) is set to the correct settings. The boiler will happily sit on pilot light but it wont fire up for water or CH. ANy ideas on what might be the problem?
chani1972
Posts: 2
Joined: Sun Feb 03, 2008 7:11 pm

Sponsor

Simply Build It

Postby ALDA » Mon Feb 04, 2008 8:50 pm

Hi Chani1972,

Did water ingress into boiler during leak?
Did you take precautions against water ingress into the boiler during your repair work?

Maybe water got onto igniter!
Maybe water got onto control boards!
Let it dry out and try again!
Maybe you could use hair dryer to speed up airing!

worth a try.

ALDA
ALDA
Posts: 397
Joined: Mon Feb 04, 2008 8:15 pm


Postby chani1972 » Tue Feb 05, 2008 2:17 pm

sorry i wasnt very clear on my first post. the leak was at the front room radiator. no water leak was near the bolier itself. it just wont fire up for heating or water
chani1972
Posts: 2
Joined: Sun Feb 03, 2008 7:11 pm


Postby htg engineer » Tue Feb 05, 2008 4:25 pm

Not familiar with this type of boiler, does it have a reset button ? could it have been switched on accidently when the system was drained and gone off on overheat ?

Does this boiler have a SIT gas valve, where the gas valve has three posiitons - Off, ignition and main flame ? is it in the correct position ?

Normally when the pilot is on, but it wont go to main flame - check there is power to the gas valve if there is - then it's a faulty solenoid.
htg engineer
Posts: 3193
Joined: Tue May 22, 2007 5:22 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics

cron