Grab Adhesive not sticking


Postby diytrouble » Mon Dec 14, 2009 8:30 pm

Can anyone tell me why the No More Nails grab adhesive I am using to stick up some architrave keeps failing. It is a new tube, and the wall is flat. The plaster is newly skimmed (about 6 months ago) but is totally dry. Does the wall need to be sealed first. I thought this type of adhesive was supposed to stick anything!
diytrouble
Posts: 1
Joined: Mon Dec 14, 2009 8:16 pm

Sponsor

Simply Build It

Postby rosebery » Mon Dec 14, 2009 11:52 pm

NMN isn't very good?

Its more than likely that the wall isn't flat and you have highspots. As a result the architrave is pulling the addy off the wall in places before it has time to set and then gravity takes over.

I'd use Gripfill or Pinkgrip in preference to NMN frankly and also plug and screw as well in order to pull the timber into the wall properly.

Cheers
rosebery
Posts: 2022
Joined: Wed Sep 26, 2007 8:55 pm


Postby chris_on_tour2002 » Thu Jan 07, 2010 9:37 pm

is the plaster dusty? give it a wipe with a slightly damp cloth and seal it with some watered down matt emulsion 60:40.

you might also want to find a way to support the architrave and hold it against the wall whilst the adhesive is drying. any whip in the architrave and it will pull away.

my favourite grab adhesive is SikaFlex-EBT personally i think it's better than gripfill as it is much stickier, has better suction so it grabs and holds better.
chris_on_tour2002
Posts: 1023
Joined: Thu Aug 30, 2007 9:14 pm


Display posts from previous
Sort by
Order by