Halstead Ace High : no hot water


Postby saqibkm » Mon Aug 06, 2007 4:05 pm

I am having problem with my combi boiler, {Halstead Ace High}. On opening the hot water tap, the boiler work fine but after 5-6 min running then burner goes off suddenly. I do not see any fault light on display /PCB either.

As the water turns cold and I turns the hot water tap off and on again. the boiler makessome checksbut fail to ignite. It appears that the pump is running. When the burner is off ; the ventilation fan is not working either. Moving the control button to RESET button in 50% cases would reignite the burner. It would appears that boiler is over heating and safety thermostat is cutting off yet ther is n't a lock out light as the Halsted fault finding diagram suggests.

Somebody in the trade suggestedto change the Air Pressure Switch. I have changed this APS but It has not solved the problem. after 10-15 minutes the boiler works again for anther 5-10 minutes.
I have changed the Hot water Thermister as well. This have not solved the mystery either.
Please suggest a solution for this misfiring of boiler.

thanks
saqibkm
Posts: 2
Joined: Fri Jul 06, 2007 9:30 am

Sponsor

Simply Build It

Postby htg engineer » Wed Aug 08, 2007 9:15 pm

Would you say the water was getting hotter than normal, or too hot ?

if the boiler extinguishes after the water is heated and then wont re-light it sounds like a its over-heating or its a faulty overheat stat.
htg engineer
Posts: 3193
Joined: Tue May 22, 2007 5:22 pm


Postby The Heating Doctor » Mon Aug 27, 2007 10:59 am

Could be the PCB, but that is expensive, have a chat with Halstead Technical they are normaly good
The Heating Doctor
Posts: 214
Joined: Mon Aug 27, 2007 9:49 am


Display posts from previous
Sort by
Order by


 


  • Related Topics

cron