Has the Central Heating Pump on my 20 Year old Boiler Broken?


Postby Ebrownie » Mon Aug 31, 2015 10:32 pm

I turned my central heating on today got the first time in a few weeks. It is a 20 year old gas boiler with a Honeywell control panel (I think 2 years old) And a wired thermostat which is also very old. We have recently moved into the house so I have no idea when the central heating was last serviced. The hot water works fine on it's timer and the boiler fires when the control panel switches on.

I put the central heating on for 1 hour today and it worked fine however when I went to put it on again this evening for another hour the panel clicked and there was a loud buzzing sound but the boiler didn't fire. I don't think the problem is with the thermostat because turning it all the way down it clicked off and the buzzing stopped. When I turned it back up to 25 degrees it clicked on again and the buzzing started.

I don't understand how I can have used the heating already today with no issue and now it has suddenly stopped. Could this be the pump?

Thanks
Ebrownie
Rank: Labourer
Progress to next rank:
50%
Posts: 3
Joined: Mon Jul 20, 2015 6:41 pm

Sponsor

Simply Build It


  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics