Heating not working properly.

Postby murf » Sun Feb 14, 2010 4:06 pm

Hello all, I'm hoping someone can help with our problem. We turned off our heating before going away recently, now we're back and things are not working properly. The system is fairly new (fitted October), hot water is fine, but the radiators are not putting out much heat, ie: radiator feels hot but room is freezing cold no more than 10c even though we have the thermostat up at 25! All was working fine before going away. PLEASE HELP. (We have a Glow worm combi boiler).
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sun Feb 14, 2010 3:50 pm


Simply Build It

Postby stoneyboy » Tue Feb 16, 2010 10:35 pm

If the radiators are hot then the system is working OK. Have you been away somewhere hot?
Rank: Project Manager
Posts: 2715
Joined: Wed Dec 10, 2008 6:44 pm

Postby DEEARR2 » Wed Feb 17, 2010 6:55 pm

Is the boiler temperature control for the heating turned upto what it was before. Hot radiators could mean 6oc passing through them when the boiler has the capacity to pass around 80c. Worth a look.
Rank: Ganger
Progress to next rank:
Posts: 160
Joined: Sun Oct 12, 2008 8:49 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics