Heating only works when Water On

Postby g60racing » Fri Nov 09, 2007 1:47 pm


We problems with our CH.

Having checked the system when I put the CH on the rads do not heat up, but if I then also put the HW on by itself the rads do heat up.

When I switch the HW on I can feel a pump near the boiler come on, should this not come on when the CH is switched on also?

We have only moved in a few months and have had little reason to turn the heating on so far.

Thanks for any help.

Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Fri Nov 09, 2007 1:42 pm


Simply Build It

Postby Mac-the-Wrench » Fri Nov 09, 2007 11:09 pm

This is how it sounds to me.

You have a hot water tank that has a water filled coil inside it which is heated up by the hot water around it. This coil is what heats the water in your radiators.

The pump should come on when the CH is switched on.

The fact it comes on when the hot water is on tells me it's not likely to be a problem with the pump. Put your hand on the pump when the CH is on, if it vibrates it's on.

It sounds more like a problem with your thermo coupler.

you should contact a Corgi registered plumber to confirm what exactly is the problem.
Rank: Apprentice
Progress to next rank:
Posts: 20
Joined: Fri Nov 09, 2007 10:48 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics