heating works but no hot water

Postby limerickian61 » Tue May 24, 2011 4:54 pm

Hi all, I have had a problem with my water not heating. The rads work but the water isn't getting hot in the tank. I had the problem reversed last year and it turned out to be the pump. Simple replacement sorted it out. There is however a continuous click coming from the pump, and according to my other half there was allot of banging going on just before it packed up. I have a gravity system, I'm not sure if this helps. Oh and its not a combi boiler either. Thank you for looking, all help would be appreciated as I cant afford to have a plumber look at it, he came round the other day and said he wanted £300 just to flush the system. Made me realise im in the wrong game
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Tue May 24, 2011 4:41 pm


Simply Build It

Postby stoneyboy » Fri May 27, 2011 5:51 pm

If you have a gravity hot water and pumped CH with no temperature control on the hot cylinder and no vent on the boiler loop on the cylinder then you have a real problem and plumber may be needed.
Otherwise check the pump is working and for a motorised valve.
Rank: Project Manager
Posts: 2715
Joined: Wed Dec 10, 2008 6:44 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics