Hotpoint DH53K - After Big Bang Main Oven Not Hot?


Postby niffysmiffy » Sun Dec 14, 2014 10:15 pm

I have a Hotpoint DH53K double oven, which is about 14 to 15 months old. A few days back there was a loud bang from the oven and the main fan assisted oven stopped heating. I checked the main element and discovered that the element had blown leaving a 4-5 mm Diameter whole in the ring. I replaced the offending element with one supplied by ransomspares.co.uk I had no issues replacing the element but once installed the main oven still does not working. I have done a continuity check on the new element the wires from the element and the switch for the main oven – all are fine. The oven does make a noise but does not get hot nor does the indicator light or fan come on. The top oven works fine as does the grill in the top oven so there is power to the oven. My thoughts now are that the thermostat needs replacing because it was damaged by the blown element.
Any advice on how to proceed would be much appreciated. Thanks.
niffysmiffy
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Sun Dec 14, 2014 8:56 pm

Sponsor

Simply Build It


  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics