Ideal HE18 flashing c


Postby gavski » Wed Aug 01, 2012 10:25 pm

I have an Ideal icos HE18 boiler.
I drained the radiator system yesterday and now the boiler has a flashing c on the led screen but won't ignite.

Normally the c flashes during the ignition and then goes on full as does the boiler light, but now I hear the boiler try to light but then stops and the light and c continue to flash.

Could this be any thing to do with me draining the heating system (I was fitting a new raditor)?
Any Ideas appreciated.
gavski
Rank: Apprentice
Progress to next rank:
89.5%
Posts: 22
Joined: Sat Oct 02, 2010 1:46 pm

Sponsor

Simply Build It

Postby gavski » Thu Aug 02, 2012 10:16 am

Answering my own post but it may help anyone with similar problem.

After draining my heating system and re-filling, I bled all radiators but there was still air in the system and that was stopping the pump from working. There was a small bleed valve in the airing cupboard, and loads of air came out when I opened it, then my boiler fired up fine; phew!
gavski
Rank: Apprentice
Progress to next rank:
89.5%
Posts: 22
Joined: Sat Oct 02, 2010 1:46 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics