Lighting circuit dead


Postby krislilley » Mon Nov 12, 2007 3:19 pm

New here so go easy!

Over the weekend the upstairs lighting circuit went dead. This has happened before and simply been a case of walking to the garage and flicking the relevant MCB back to on. However, on this occasion the MCB is set at 'on' but none of the upstairs lights are working. Everything else in the house is fine. Is this particular MCB knackered? (for info, i cut the power and took the MCB in question to my local DIY store but cannot find the same type. It is a 5A MCB).

Could anyone offer any advice?

Cheers
krislilley
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Mon Nov 12, 2007 3:13 pm

Sponsor

Simply Build It

Postby kuzz » Mon Nov 12, 2007 7:58 pm

Sounds like the mcb is knackered. When they trip internally but not externally can normally get them to reset by turning them on and off a few times. The real long term answer however is to get a new mcb. You'll have more luck if you try a proper electrical wholesalers.
kuzz
Rank: Ganger
Progress to next rank:
56%
Posts: 134
Joined: Sat Nov 03, 2007 3:37 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics