Lights Stop Working

Postby sidewinder316 » Sat Feb 23, 2008 9:45 am

HELP!! - I have recently changed my on-suite centre light (ceiling rose) for 5 x indivudual downlights. I disconected all the wires from the ceiling rose 9power off) and pushed them all through to the loft above. I reconnected the wires again back onto the ceiling rose (I think this is where the problem is) in what i think is the correct order and I now have lost lighting in 4 rooms and a landing. The 5th bedroom (my daughters) lights work fine no problem. Also the extractor fan in the en-suite is working also.

I seem to have tried every configuration possible with the wiring at the ceiling rose but still no joy. I have 3 black (one with red sheathing on) 3 Red 9ine with additional red sheathing on) and the earth wires. Currently I have the 3 red wires going into the centre 3 block connector on the ceiling rose, two black wires into the three block connector and the 'switched' live into the two block connector.

Can anybody advise if this correct or advise what I need to do to change it.

Many thanks

Steve L
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sat Feb 23, 2008 9:36 am


Simply Build It

Postby ericmark » Sat Feb 23, 2008 9:27 pm

What you say as to how connected sounds correct. Either one wire not in correctly or broken within the insulation only way with power off is to pull on reds and blacks in the three way connectors and check for brakes. Sorry we can't be of any more help.

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics