Makita mitre saw not working

Postby wakeboarder » Thu Sep 06, 2012 10:03 pm

Hello Guys, First post here. I have a makita LS1018 mitre saw, Its about 2 yr old and had light D.I.Y use around The home and garden. Got it out today and its not working, Fuse is OK and no Nick's in cables etc. anyone got any idea at to the problem before I take it to specialist/repairs thanks.
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Tue Sep 04, 2012 10:53 pm


Simply Build It

Postby Mad110 » Wed Jul 22, 2015 8:22 pm

Check the motor brushes, ( large slotted plastic screw either side of motor housing). Or a simple as it sounds, cut off the moulded plug and replace with a new one. Sometimes the neutral wire can bake and break inside the plug housing. Failing that the safety button or main switch may be broken. There are some good repair videos on YouTube. Don't be scared to take the covers of and stick a multimeter on the wiring( unplugged of course). You get to know your tools better if you HAVE to put em back together.
Rank: Apprentice
Progress to next rank:
Posts: 19
Joined: Wed Nov 26, 2014 9:20 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics