Mira 415 shower only has cold water coming out

Postby arupm » Sat May 16, 2009 8:04 am

We have a Mira 415 shower than is connected to a combi boiler. For some reason it is only running out cold water. However if we have the radiators on it does give out hot water! It seems that we can only have hot showers if the heating system is on.

the boiler has been fully serviced so cannot see how it can be that.

Thought it might be a mixer valve not working - but not sure what that is as someone else suggested this. But how can this be the case if when the heating is on we do get hot water out of it?

Any help would be greatly appreciated as I have three kids who are sick of cold showers in the morning as it takes a while for the heating to get the shower to run hot enough.

Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sat May 16, 2009 7:49 am


Simply Build It

Postby rosebery » Sat May 16, 2009 2:51 pm

"the boiler has been fully serviced so cannot see how it can be that."


Flow switch or diverter valve I'm thinking.

Rank: Project Manager
Posts: 2022
Joined: Wed Sep 26, 2007 8:55 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics