New Radiator Fitted and Now no Hot Water?


Postby Colwood63 » Thu May 22, 2014 9:29 pm

Hello

I am new here and have just bought my first house. Have been doing renos and last night had a new radiator fitted by a plumber. All seemed to be fine except today I have no hot water. Also the overflow pipe is now dripping. Finally, the multihead G pump is now really noisy when the hot water is turned on. None of these problems existed prior to yesterday so they must be related to the rad being fitted right?

Can anyone advise? I would like to fix myself if possible without getting plumber out again.

Thank you!
Colwood63
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Thu May 22, 2014 9:17 pm

Sponsor

Simply Build It

Postby proptech » Fri May 23, 2014 11:00 am

Hi Colwood63

It sounds like there is still air in the system after being drained. Your plumber should have made sure that all was working correctly before leaving.
In order to advise for a DIY remedy we would need a lot of info on the system. The best course of action would be to get the plumber back, and don't try to use the system in the meantime, if the pump is running dry, it could be damaged.
proptech
Rank: Foreman
Progress to next rank:
71.7%
Posts: 415
Joined: Wed Dec 05, 2012 11:22 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics