No central heating - twin pump heating system

Postby morrismob » Tue Oct 02, 2007 8:12 pm

We have a floor mounted boiler in the garage, this has twin pumps fitted, possibly as we have 13 radiators in the house ? Dunno..
There is one pump either side of the boiler, a room stat in the dining room and a tank stat on the hot water tank - hot water seems to work fine..
When the heating is turned on, we get nothing. And feeling the pumps, only 1 pump runs - is this correct or should both run together ?
When I turned the silver centre screw, the running pump had water come out, but the pump which soesn't run just had steam hissing out..
The room stat can be turned to max and still no heating, the boiler fires up, runs for approx 2 mins and then cuts out again..
I am wondering if this is a room stat problem, and/or a pump fault or even the 3 way valve faulty..
Most of the radiators last year seemed only warm at the top 3/4 and didn't get as hot as would be expected.. Should we remove and flush all radiators too ?
Any ideas or info on testing what should work and when would be most appreciated before my kids finally freeze to death - as they keep telling me.
Many thanks, Andy.
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Tue Oct 02, 2007 8:00 pm


Simply Build It

Postby The Heating Doctor » Fri Oct 12, 2007 12:07 am

Too many variables, impossible to answer on a forum. Time to bite the bullet and call in a heating engineer
The Heating Doctor
Rank: Foreman
Progress to next rank:
Posts: 214
Joined: Mon Aug 27, 2007 9:49 am

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics