Potterton Electronic PCB (type 407676) issue


Postby SSdF » Wed Sep 11, 2013 5:18 am

Dear All,

When switch on the boiler does not fire up, but a clicking noise coming from the circuit board; this clicking noise is coming from the relays on the board, trying to set (but instead of click and set continuously trying to switch) . This clicking is continuing (and boiler does not fire up)until the boiler is completely switched off. I can see the SG1 firing inside (blue spark ). The fuse is fine, no visible burnt out parts etc. and no dry joints on the board. I think the noise is one of the relays is trying to set but it does not happening. (The boiler starts with a big click when switched on, and a fan or a motor starts running but does not getting fired up). I believe something wrong with the circuit board.

I would be very grateful to you, if you could please let me know which parts may be required to be replaced or whether the problem is with the circuit board ( and whether the Circuit board needs to be replaced, or what else I need to be checking)?

With thanks and regards, DY

PS: Boiler is Potterton Netaheat 10/16 Electronic and the circuit board (Boiler Control) type no is 407676.
SSdF
Posts: 4
Joined: Sun Jan 23, 2011 10:06 pm

Sponsor

Simply Build It

Postby proptech » Thu Sep 12, 2013 9:31 pm

Hi
This problem may be as simple as a fault with the electrode, or with the pilot burner. BUT, Working on a gas appliance is not a DIY job, so please get a Gas Safe engineer to take a look at it. Safety first !
This is quite an old boiler, and parts may not be available, and expensive if they are, so be warned !
proptech
Posts: 162
Joined: Wed Dec 05, 2012 11:22 pm


Postby SSdF » Sat Sep 14, 2013 9:43 am

Hi Prpotech,

Many tanks, SSDF
SSdF
Posts: 4
Joined: Sun Jan 23, 2011 10:06 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics