Potterton Kingfisher MF


Postby Emulated » Fri Jun 11, 2010 3:26 pm

My Potterton Kingfisher MF fires instanly on initial start up but once it has done a cycle of heating the hot water and whilst the boiler is still warm the relay clicks about 5 times and it takes several goes to fire up. I had the thermostat replaced but it made no difference.
Emulated
Posts: 4
Joined: Fri Jun 11, 2010 3:10 pm

Sponsor

Simply Build It

Postby htg engineer » Sat Jun 12, 2010 11:57 am

You need an RGI to check and adjust pilot, once the appliance is warm there's a better pull on the flue, a dirty or poor pilot the gas is pulled away from the pilot - so the gas air mixture isn't correct.


htg
htg engineer
Posts: 3193
Joined: Tue May 22, 2007 5:22 pm


Postby Emulated » Sat Jun 12, 2010 1:06 pm

Many thanks. Maybe the service man failed to understand the problem and simply fitted a new temperature control. I will ask him to recall and see how it goes.


htg engineer wrote:You need an RGI to check and adjust pilot, once the appliance is warm there's a better pull on the flue, a dirty or poor pilot the gas is pulled away from the pilot - so the gas air mixture isn't correct.


htg
Emulated
Posts: 4
Joined: Fri Jun 11, 2010 3:10 pm


Postby eggers » Mon Jul 05, 2010 9:17 pm

is it open flued mf or room sealed?
the air intake on the open flued mf do get clogged easily, but it could be a blocked pilot, or a flame rectification fault
eggers
Posts: 97
Joined: Mon Jul 05, 2010 8:57 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics