Potterton profile 80e - doesn't fire up immediately.


Postby Dabs » Mon Nov 24, 2008 3:18 pm

I've got a strange problem with my Potterton 80e.

The boiler fires up ok on heating, but on hot water demand the boiler starts to fire up and then switches off. It cycles like this for a while i.e tries to fireup-->turns off-->tries to fireup-->turns off before eventually firing up ok. Once it has started everything seems to work fine but it repeats the above cycle several times during operation.

Would anybody be able to tell me what is causing this.
Dabs
Posts: 3
Joined: Mon Nov 24, 2008 3:05 pm

Sponsor

Simply Build It

Postby htg engineer » Tue Nov 25, 2008 11:56 am

Could be a faulty DHW flow switch or microswitch.

Does it work ok on CH ? this would rule out an ignition problem.

htg
htg engineer
Posts: 3193
Joined: Tue May 22, 2007 5:22 pm


Postby Dabs » Tue Nov 25, 2008 12:53 pm

Central heating fires up ok as soon as you switch it on.

DHW will fire up eventually, it just has goes through a on/off cycle several times before it ignites.

Not sure if it is a main PCB fault, that s what plumber diagnosed over phone when I explained symptoms. Not convinced though.
Dabs
Posts: 3
Joined: Mon Nov 24, 2008 3:05 pm


Postby gasmick » Tue Nov 25, 2008 11:04 pm

Hi i would think its more like a diaphram problem in the domestic part of the valve they are prone to getting shredded anmd worn out ther is a micro switch on the end that closes when calling for water but if the diphram is faulty it will take a couple of times before enough pressure builds up behind it i would say the p c b is ok as the boiler is functioning ok on the heating

mick
gasmick
Posts: 44
Joined: Mon Nov 24, 2008 9:09 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics

cron