Potterton Puma 80 Boiler not firing


Postby slant » Sun Jun 08, 2008 9:25 am

I have a Potterton Puma 80 boiler and it wont fire. Initially the boiler was showing low pressure warning light, pressure gauge was was up in 4 bar, i bled a radiator and got it down to 1.5 bars but still the low pressure light was showing. I was told the water pressure switch may need cleaning. I then read a post on a forum that said a few light taps with a hammer may dislodge any dirt, I did this, turned boiler on and indeed the low pressure warning light had gone, however the boiler still did not fire up, then the pilot light went out. I left it for 1/2 hr turned it back on light the pilot light and the system fired up fine. This morning (2 days later) the boiler wont fire up again and the low pressure system light is still not showing, pressure dropped slightly to 1 bar, ive re-pressurized to 1.5 and still nothing. Can someone shed some light on the possible problem and way to resolve it. I am going to clean/replace water pressure switch as this may have become blocked. thanks.
slant
Posts: 1
Joined: Sun Jun 08, 2008 9:13 am

Sponsor

Simply Build It

Postby htg engineer » Sun Jun 08, 2008 10:48 am

If i remember rightly - bottom left on PCB, an electrical connector with 2 yellow wires - disconnect this, try boiler if it's working then it's the low system pressure switch at fault.

If the pilot keeps going out - does the boiler make any noises ? could be over-heating.

ISOLATE ELECTRICAL SUPPLY before attempting above.

htg
htg engineer
Posts: 3193
Joined: Tue May 22, 2007 5:22 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics