Potterton Suprima 60L sequence on and off


Postby russH » Thu Jan 08, 2009 2:10 pm

Hi

I have a 4 year old Suprima 60 L . My system is open vented fully pumped and has a Honeywell mid position Y plan valve.
My question is regarding the Control Sequence and normal way of running.
The start sequence starts as stated in the manual. However the burner only stays on for about 3 mins it then goes off (not locked out ie does not need resetting) the pump remains running (overruns for the designed 2 mins) The pump then stops just for a second or so... and the sequence starts all over again. The system runs like this until the room stat is satisfied. I have tried higher and lower settings on the boiler temperature control but if make little difference ( when temp control is lower the burner goes off after say 2 mins or so). Is this normal or should the boiler run continuously until the room stat stops it?
The above sequence also happens if hot water only is selected.

I have also tried chaning the speed setting on my pump.
russH
Posts: 2
Joined: Thu Jan 08, 2009 2:07 pm

Sponsor

Simply Build It

Postby Steve the gas » Fri Jan 09, 2009 5:53 am

Hi Russ,


Follow the fault flow chart in the manual, to trace fault.But sounds a PCB fault poss.

Hth
Steve the gas
Posts: 780
Joined: Sun May 04, 2008 7:07 am


Postby russH » Mon Jan 12, 2009 1:17 pm

Thanks. The flow chart is not much help. Additional information. When I start my heating from cold the boiler stays on and heats the rads' for about 15mins or so. The room stat is not satisfied when the boiler starts to then cycle on an off.
russH
Posts: 2
Joined: Thu Jan 08, 2009 2:07 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics