Powershower - No cold water coming through


Postby Rupkali » Sat Apr 12, 2008 1:46 pm

Hi

I have no cold water coming through our Powershower. There is cold water coming through all the cold taps in the bathroom - sink and bath.

We have a Stuart Turner Showermate twin pump.

The problem has happened since I changed a tap washer on the cold water tap (bathroom sink).

In doing this I drained the cold water tank. Didn't intend to but I didn't seem to be able to turn off the outlet tap which was on a lower pipe exiting the cold water tank. Perhaps, I couldn't turn this off because we have a Powershower.

I suspect I should have isolated the Pump when draining the tank and that I have now introduced air into the pump on the cold water side.

My question - am I able to release the air from the cold water side of this pump easily.

Clearly from my error of draining the cold water tank I am not very capable at DIY. It maybe an air lock isn't the issue at all but from what I have read this morning on the Net, it seems a plausible cause.

Any help much appreciated.
Rupkali
Posts: 2
Joined: Sat Apr 12, 2008 1:36 pm

Sponsor

Simply Build It

Postby chris_on_tour2002 » Sun Apr 13, 2008 8:10 pm

try loosening the thread on the pipe connecting the pump to the shower with the pump on, that might let the air out. be warned though - the pump could activate at any given moment! so be ready and have someone on standby to trip the isolator switch.
chris_on_tour2002
Posts: 1023
Joined: Thu Aug 30, 2007 9:14 pm


Postby Rupkali » Mon Apr 14, 2008 11:31 am

Thank you very much - all sorted with venting the pump.

cheers.
Rupkali
Posts: 2
Joined: Sat Apr 12, 2008 1:36 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics