Push Button Cistern - noises 10 minutes after flushing


Postby CJ » Wed May 09, 2007 7:49 am

I have had several problems with my cistern which is only 2 years old - each time I have had to call on DynoRod to fix them. However I now I have a new problem. About 10 mins after flushing the cistern starts making a noise like the rummble of a motorbike starting up (don't laugh) the silver flexible hose attached to the cistern vibrates, I then have to slightly depress the button to release a little bit of water wich makes a gurgling noise and then the rumble stops. Next time it is flushed again the same noise after 10 mins. Any ideas?
CJ
Posts: 4
Joined: Thu May 03, 2007 1:18 pm

Sponsor

Simply Build It

Postby peter the plumber » Thu May 10, 2007 12:24 am

Its a £12 part and easy to replace.

There something simple wrong with it, but I feel you would be better off just replacing it.

The push button cistern valves that come with a new cistern are always a "bit too cheap" and most of the time we just throw them away and replace them with a better ones.
peter the plumber
Posts: 197
Joined: Wed Mar 28, 2007 9:19 am


Postby peter the plumber » Thu May 10, 2007 3:20 am

Forget what I have just said on this subject.

I think was replying to a different post or just had a bad kebab.

You need a new entry valve and they start at about £3

They’re not worth repairing.

Just turn off the water and it’s a 5 mins job
peter the plumber
Posts: 197
Joined: Wed Mar 28, 2007 9:19 am


Display posts from previous
Sort by
Order by


 


  • Related Topics