Radiators not working but hot water is?


Postby homesolutions » Tue Oct 23, 2007 5:18 pm

Hi Everyone, i had a leak on one of the radiators where i am working so i had to take the rad of and fix the fitting which meant draining the system.
The system did drain and as it as an expansion tank it filled back up and all the radiators all have water in them and when you bleed them water comes straight out.
Only problem is that it is not getting hot when you put the heating on so any ideas would be great please..
Kind regards
Lee
homesolutions
Rank: Apprentice
Progress to next rank:
63.2%
Posts: 17
Joined: Mon Oct 22, 2007 8:36 pm

Sponsor

Simply Build It

Postby htg engineer » Tue Oct 23, 2007 8:16 pm

Make sure both valves are turned on to each radiator.

And the pump will require venting if you have drained the system, it is also possible to be airlocked, so turn all radiators off except one and see if it heats up.

Also check near tank / cylinder for any manual air vents.
htg engineer
Rank: Project Manager
Posts: 3224
Joined: Tue May 22, 2007 5:22 pm

Postby homesolutions » Tue Oct 23, 2007 9:39 pm

Hi there how do you vent the pump please?
Kind regards
Lee
homesolutions
Rank: Apprentice
Progress to next rank:
63.2%
Posts: 17
Joined: Mon Oct 22, 2007 8:36 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics