Ravenheat CSI 85 AAA Boiler Pressure Gauge not Registering When Filling


Postby Pandora111 » Sat Jan 23, 2016 1:35 pm

Hey guys,

I have a problem with a brand new fitted Ravenheat CSI 85 AAA boiler.
I own second property where I fitted this brand new boiler a year and a half ago. The system was never filled until 3 weeks ago and the pressure gauge does not register when filling. This obviously now will be out of warranty. Would the expansion vessels pressure affect the gauge working and what psi should the vessels be? I do not wish to fork out £60 on a new water gauge if this is not the problem.

The boiler does heat the water but the heating only works when I run the hot taps first so kicking in the pump. With the pressure gauge being on zero the heating will not kick in on its own. All the valves are open correctly.
I never registered the boiler as it is an empty flat where I lived 3 years ago and have just not got round to finishing renovations due to health problems.

If the expansion vessel has not been pumped with any pressure could this be causing the problems I am having?. I am not a domestic boiler expert so any advice would be appreciated.
Pandora111
Rank: Labourer
Progress to next rank:
25%
Posts: 2
Joined: Sat Jan 23, 2016 12:48 pm

Sponsor

Simply Build It


  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics