Sabre HE 3 Second Blinking Green Then Flashing Red When On


Postby tobyd10 » Mon Feb 01, 2016 9:47 pm

Hello.
My Sabre HE stopped working this morning after working fine.
I have done lots of searches and tried the venturi 'clean with a piece of wire' but to no avail. I am still unsure how to get the second venturi out as it fits from the inside of the fan assembly - do I need to take the fan assembly out?
I have a 3 second blinking green light which doesn't fit with the patterns described in the manual.
When there is a demand for hot water or central heating I get an instant red .5 second flashing light. The pump runs and the fan seems to spin but no clicking from the differential pressure switch and no ignition. If I blow through the clear + pressure tube the switch clicks and also with a suck on the negative tube.
After tryin to start the boiler continues to make the pump/fan noise for about 25 seconds then stops.

Is the any other simple tests/ fixes I can try? How can I test if power is getting to the differential power switch?

Thanks for any help and your time to read the post.
Cheers
Toby
tobyd10
Rank: Labourer
Progress to next rank:
0%
Posts: 1
Joined: Mon Feb 01, 2016 9:44 pm

Sponsor

Simply Build It


  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics