Shower pull cord switch is not working


Postby advance » Tue Jul 06, 2010 6:58 pm

Hi,
I have a problem with the pull cord switch it will not turn on the power for the shower unit. It operates off and on ok but shows no light indicator when in the on position and there is no light on at the shower unit. Could it be a fault in the switch ?
It has made some 'rumbling noises' in the past few weeks that I have thought maybe to do with other appliances using water at the same time
Its a Mira Advance shower and is at least 10 years old
All replys appreciated
Thanks
advance
Posts: 1
Joined: Tue Jul 06, 2010 6:39 pm

Sponsor

Simply Build It

Postby ericmark » Wed Jul 07, 2010 7:16 am

If both lights failed together then yes likely switch however the neons in switches do fail quite regular so I would not rely on them.
What made 'rumbling noises' if the switch then very likely faulty they should not make noises like that. If shower then one wonders if shower is faulty.
Very likely you have a RCD and a MCB feeding shower or a combination unit called a RCBO and likely these are either in consumer unit or by consumer unit. You may even have a fuse. You need to find these anyway to isolate supply and when I don't now earthing system I advise you always use main isolator before working on an appliance hard wired as many trips only switch the line live supply and not the neutral live supply. Be aware if the switch is faulty if you open it you may not be able to put back together so do find the isolation points first.

I don't like advising people to DIY as I have seen some DIY horrors in my time and unless you know what you are doing and how to do safely I would always advise you to get an electrician. Especially with a shower.
ericmark
Posts: 1240
Joined: Fri Oct 02, 2009 8:49 pm
Location: Mold, North Wales.


Display posts from previous
Sort by
Order by


 


  • Related Topics