Shower Pump Problem - Need advise


Postby antonynutley » Wed May 16, 2007 12:29 am

Had the same water system in my house for 2 years and everything has always run well. However a couple of weeks ago the ballcock in the cold tank in the loft broke and the tank ran dry, the next day it had filled up again - and everything was working again, however a few days later I changed the ballcock anyway and again everything was fine, but 2 days later the shower is struggling, on just a hot setting it works but on a cold mixed setting it keeps stopping and starting and then finally dies. The water tank in the loft is full and seems to be doing its job, any ideas where to look for the prob??

Thank you!!
antonynutley
Posts: 2
Joined: Wed May 16, 2007 12:25 am

Sponsor

Simply Build It

Postby Arnak » Wed May 16, 2007 9:18 am

Hi,

It he shower an electric or a mixer?

I presume that the hot and cold taps are running ok in the other taps?

Arnak
Arnak
Posts: 37
Joined: Fri May 11, 2007 9:55 pm


Postby antonynutley » Wed May 16, 2007 12:06 pm

Hi, yes all other taps are working correctly, it is an electric shower pump which sits in a seperate cupboard in the landing. Thanks!
antonynutley
Posts: 2
Joined: Wed May 16, 2007 12:25 am


Postby Arnak » Wed May 16, 2007 2:02 pm

Hi,

Best guess then is that there is a problem with the shower pump. :(

I suppose that you could isolate the water supply to the shower then disconnect the incoming supplies so that you can turn them back on to see if both the hot and cold are being pumped successfully.

I assume that both the hot and cold are pumped, if so then both outlets to the shower should be under the same pressure.

That's the best I can suggest without seeing the installation.

Arnak
Arnak
Posts: 37
Joined: Fri May 11, 2007 9:55 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics

cron