Smeg Oven not heating at all


Postby terbrads » Mon Sep 01, 2008 1:17 pm

I have a SMEG oven (model SE378MFX5) which is about eighteen months old. It has been used quite a lot and I have mostly only used the fan cooking option which relies on one of three elements which is in the centre of the oven. About two weeks ago this element stopped heating up so I carried on cooking using the upper and lower element options until I could get a replacement for the fan element. That was okay until I went to use the oven on the weekend and it wouldn't heat at all. The main oven light comes on and there is a lower fan which was turning okay but the centre fan wouldn't turn and the orange heat indicator light didn't come on either. Could it be the thermostat? I am not going to try to replace it myself but would like a heads-up if possible before bringing in an engineer.
I would be very grateful for any advice,
thanks,
Terry.
terbrads
Posts: 2
Joined: Mon Sep 01, 2008 12:20 pm

Sponsor

Simply Build It

Postby terbrads » Wed Sep 03, 2008 6:13 am

Found the problem. Had removed the door to clean oven and not re-fitted correctly. There is a cut-out switch behind the RH hinge. Have re-fitted door correctly and oven is working again.
terbrads
Posts: 2
Joined: Mon Sep 01, 2008 12:20 pm


Postby TheDoctor5 » Tue Jan 20, 2009 9:58 am

Last year 64% of the questions asked in our forum were answered within our DIY project pages at www.diydoctor.org.uk/projects.htm The project pages are now separated alphabetically and your answers are accompanied by diagrams and the ability to see, and buy, the tools and/or required to complete your project. Use our search box to look for your answer and save a great deal of time and money!
TheDoctor5
Site Admin
Posts: 1385
Joined: Tue Jan 20, 2009 9:17 am


Display posts from previous
Sort by
Order by


 


  • Related Topics