time delay light switch won't switch off


Postby parkejr » Wed Jan 07, 2009 8:34 am

Recently I installed a fluorescent light fitting in my garage with a single pole switch, and it worked fine.

I've now taken the switch off and replaced it with a time delay switch, where I press the button, and the light should come on for about ten minutes, and then switch off by itself.

but the light stays on all the time.

The wiring is pretty straight forward. Live feed comes in, and the output goes to the light, after which it returns to neutral.

Any thoughts as to why this might happen? I have a pneumatic and an electronic switch, and the same thing happens with each.

Thanks,

Jeff.
parkejr
Posts: 8
Joined: Sun Jan 13, 2008 10:37 am

Sponsor

Simply Build It

Postby BLAKEY1963 » Thu Jan 08, 2009 9:56 am

[quote="parkejr"]Recently I installed a fluorescent light fitting in my garage with a single pole switch, and it worked fine.

I've now taken the switch off and replaced it with a time delay switch, where I press the button, and the light should come on for about ten minutes, and then switch off by itself.

but the light stays on all the time.

The wiring is pretty straight forward. Live feed comes in, and the output goes to the light, after which it returns to neutral.

Any thoughts as to why this might happen? I have a pneumatic and an electronic switch, and the same thing happens with each.

Thanks,

Jeff.[/quote]

JEFF
if your permanent live , and switch live r correct as per the instructions 4 the item , it could b faulty. seek advice from the supplier.

BLAKEY1963
BLAKEY1963
Posts: 654
Joined: Wed Jun 13, 2007 10:57 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics