toilet not flushing.


Postby safetyman » Tue Jul 15, 2008 8:38 pm

Help please, after looking at the responses to earlier problems of toilet flushing i identified that i needed a new syphon which i duly bought and fitted (close coupled) however after a number of hours of frustration and attaching the handle levers and hook in various positions i am still unable to flush the toilet properly some times it takes two flushes others theree or four, i have checked the stop cock valve and all is ok. if i pull the syphon hook up directly by hand hard then it flushes first time. The water level in the toilet comes to the same level as previous when refilling. i do not have any leaks the unit is a 9.5 inch high syphon from B&Q. i have looked closely at the unit and can not see anytthing faulty with it.
Advise greatly appreciated.
Thanks. :cry:
safetyman
Posts: 2
Joined: Tue Jul 15, 2008 8:25 pm

Sponsor

Simply Build It

Postby nitro23456 » Sat Jul 19, 2008 7:10 pm

water level.
nitro23456
Posts: 346
Joined: Sun Aug 12, 2007 6:19 pm


Postby htg engineer » Sat Jul 19, 2008 8:35 pm

Can you shorten the hook - as it works everytime by hand - maybe the handle is not lifting it up enough to flush ? any movement on handle that could prevent it from working everytime ?

htg
htg engineer
Posts: 3211
Joined: Tue May 22, 2007 5:22 pm


Postby safetyman » Sun Jul 27, 2008 10:45 am

Water level has been tried at same level and higher than before. Tried shortnening the hook did not make any difference, however i have noticed that sometimes the handle does not come back on its own on other times it is slow to come back up so i shall play about with the combination of positions on the plastic lever again to see if that makesa difference, thaks for the response.
safetyman
Posts: 2
Joined: Tue Jul 15, 2008 8:25 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics