Triton Jade 2 Fault


Postby Mark L » Tue Aug 31, 2010 1:40 pm

Our Triton jade 2 has worked fine for two years or so but now has stopped working - no water hot or cold. When the on button is pushed, the 'Low Pressure' light comes on and basically nothing happens, not a gurgle or a drip. Is something blocked on the cold water feed side or is it just dead? Advice much appreciated.

Thanks
Mark
Mark L
Rank: Labourer
Progress to next rank:
50%
Posts: 3
Joined: Tue Aug 31, 2010 1:34 pm

Sponsor

Simply Build It

Postby plumbbob » Wed Sep 01, 2010 10:44 pm

It could be a blocked inlet filter, but if there is no water from the shower head at all, the most likely culprit is a failed solenoid inlet valve.
plumbbob
Rank: Project Manager
Posts: 1873
Joined: Wed May 07, 2008 9:59 pm

Postby Mark L » Fri Sep 10, 2010 9:32 am

Thanks for that - have ordered the part and will be fitting soon, any tips on fitting it, just on the off chance it proves difficult??
Mark L
Rank: Labourer
Progress to next rank:
50%
Posts: 3
Joined: Tue Aug 31, 2010 1:34 pm

Postby plumbbob » Fri Sep 10, 2010 4:45 pm

I don't think there is any particular issue with fitting a valve, although you may find the whole unit will have to be removed from the wall as you might find difficulty with disconnecting the incoming water connection.
plumbbob
Rank: Project Manager
Posts: 1873
Joined: Wed May 07, 2008 9:59 pm

Display posts from previous
Sort by
Order by



  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!



 


  • Related Topics