Two cold radiators


Postby Myrtle » Mon Aug 04, 2008 6:07 pm

Ever since moving into my house a year and a half ago, just two of my radiators don't appear to work. The whole system had been drained prior to my moving in so we re-filled the system and bled all the radiators. The boiler is on the first floor (in the bedroom believe it or not!). The two failing radiators are downstairs. One is in the bathroom, although the kitchen radiator that precedes it works fine. The other one that doesn't work is in the dining room, although the lounge radiator that is beyond it works fine. The pipes up to the valves get warm in both cases. If I try and bleed these radiators I get water straight away and no air. The valves appear to be standard manual valves from what I can tell - not thermostats and they have white cap over a lug that sticks up it that means anything to those who know. Is there something obvious I can try before getting the plumber in? All of the upstairs radiators and the one in the loft work fine. Cheers.
Myrtle
Posts: 10
Joined: Mon Aug 04, 2008 5:40 pm

Sponsor

Simply Build It

Postby Steve the gas » Tue Aug 05, 2008 5:16 am

Hi Myrtle,

It's ok to have a boiler in your bedroom - it will probably be a room sealed appliance!

The no-workin rads maybe as simple as the valves are closed.
So open them (the lugs under the caps as you say) see what happens?

Hth

Steve
Steve the gas
Posts: 780
Joined: Sun May 04, 2008 7:07 am


Postby htg engineer » Wed Aug 06, 2008 11:02 am

Check all radiator valves are open, check pressure and vent the radiator.

Still no luck ? turn off all radiators apart from the 2 problem radiators, it could just be air in the system. Run the heating and see if it clears.


htg
htg engineer
Posts: 3193
Joined: Tue May 22, 2007 5:22 pm


Postby Myrtle » Wed Aug 06, 2008 7:14 pm

The valves definitely open. I will try closing all the others and running. Thanks.
Myrtle
Posts: 10
Joined: Mon Aug 04, 2008 5:40 pm


Display posts from previous
Sort by
Order by


 


  • Related Topics