Vaillant Combi fault

Postby Davethediver » Sun Aug 17, 2008 2:34 pm

Hi there
I have a Vaillant combi approx 7years old and to be honest it has always been a bit iffy from day 1...water going cold while the bath has half filled etc.
The problem is that when the heating is turned off and the water only is selected, the heating comes on regardless. I have turned down the roomstat to nil and it appears to be functioning normal. The only way in any format to get hot water only is to have the heating on. I do not have a timer clock fitted to my system so that would eliminate that poosible cause.
So, what do you think guys?
I am pretty ept in most fixits so, is this a job I could do myself. On a diy scale of 1-10 I am about 8.
Rank: Labourer
Progress to next rank:
Posts: 1
Joined: Sun Aug 17, 2008 2:15 pm


Simply Build It

Postby htg engineer » Mon Aug 18, 2008 3:23 pm

If you're getting heating when hot water selected or you can only get hot water with the heating on - it'll probably be the diverter at fault.

htg engineer
Rank: Project Manager
Posts: 3224
Joined: Tue May 22, 2007 5:22 pm

Display posts from previous
Sort by
Order by

  • DIY How to Project Guides

  • DIY how to tutorial projects and guides - Did you know we have a DIY Projects section? Well, if no, then we certainly do! Within this area of our site have literally hundreds of how-to guides and tutorials that cover a huge range of home improvement tasks. Each page also comes with pictures and a video to make completing those jobs even easier!


  • Related Topics