Vaillant EcoTEC Pro 24 Combi-Boiler not Turning on When Thermostat Turns on


Postby Joe1234567 » Wed May 28, 2014 9:32 pm

Hi

I have a Valliant ecoTEC pro 24, with a Drayton Digistat SLR wireless thermostat. It was installed about 3.5 years ago.

I'm pretty confident the thermostat is working - I can see the flame symbol come on and off as the temperature rises and falls, and also as I turn the thermostat to hotter or cooler.

When the flame symbol on the thermostat turns on or off, the Digistat blinks red, and then the green light comes on (or goes off if turning off).

The problem is that when the green light on the digistat goes on, it doesn't always cause the boiler to turn on. So sometimes during the day the flat will get cold because the radiators are not hot.

The timer control is set to "on" (not "off", and not "timer"), so I'm assuming it's nothing to do with the timer settings.

I have found that I can temporarily fix this by turning the boiler on and off, and then turning the thermostat down and then up again. This causes the green light on the digistat to come on, the boiler to fire, and the radiators to get hot.

If, after the flat has gone cold, I try turning the thermostat down and then up again but without turning the boiler on and off, then the green light on the digistat comes on but the boiler does not fire.

This approach has worked for the last few weeks, I usually need to do it once a day. This evening however, it didn't work. I finally got the boiler to fire by removing the timer panel and then turning the boiler on and off and turning the thermostat down and up.

Any clues??

Many thanks

Joe
Joe1234567
Posts: 1
Joined: Wed May 28, 2014 8:48 pm

Sponsor

Simply Build It


 


  • Related Topics